Microsoft 365 customers be advised Microsoft incident EX682041 is resulting in some tenant admin contacts being BCC'd on outbound messages being incorrectly flagged as spam
Incident Report for Inky
Resolved
Microsoft has confirmed that they believe that they have corrected the impact from this incident.
Posted Oct 17, 2023 - 21:01 UTC
Monitoring
Please be advised that Microsoft has issued an incident EX682041 indicating that they are working on an issue affecting their outbound spam filter policies. Tenants that have an admin contact defined in their outbound spam policy may be BCC'd on messages sent by their users that Microsoft is incorrectly flagging as spam. Microsoft is working on the issue and Inky will be continuing to monitor the event.
Posted Oct 17, 2023 - 19:28 UTC
This incident affected: Email Processing (Inky Region 1 - Southeast US, Inky Region 2 - Eastern US, Inky Region 3 - Northwest US, Inky EU).