Delays in mail delivery for Office 365 customers
Incident Report for Inky
Resolved
Normal service has been restored to all regions
Posted Sep 21, 2021 - 19:42 UTC
Investigating
Inky is investigating an incident that may result in a delay in receiving O365 messages for several minutes. We are investigating the cause and insuring that no further impact is experienced.
Posted Sep 21, 2021 - 19:30 UTC
This incident affected: Email Processing (Inky Region 1 - Southeast US, Inky Region 2 - Eastern US, Inky Region 3 - Northwest US).