Inadvertent routing of mail to quarantine/junk in EU
Incident Report for Inky
Resolved
This incident has been resolved.
Posted Jul 15, 2022 - 18:49 UTC
Monitoring
Microsoft has identified and begun internal remediation actions to correct the delivery of email incorrectly quarantined. Inky will continue to monitor the situation and has requested details from Microsoft on what caused the incorrect classification of domains.
Posted Jul 15, 2022 - 15:42 UTC
Update
Microsoft has determined that the listing was an error they have corrected the issue and are beginning an internal process to correct the error and properly deliver messages
Posted Jul 15, 2022 - 14:32 UTC
Update
We are continuing to investigate this issue.
Posted Jul 15, 2022 - 14:31 UTC
Investigating
At this time, we have determined that Inky domains in the EU is being flagged as dangerous incorrectly. This is causing Microsoft to immediately route any messages that contain a link with Inky EU domains into quarantine or junk. Our US-based service is unaffected. Inky has engaged Microsoft and is investigating corrective measures at this time.
Posted Jul 15, 2022 - 14:25 UTC
This incident affected: Dashboard Services (Dashboard Services EU), Link Rewriting service, and Email Processing (Inky EU).