Issues delivering emails to Microsoft Groups/DLs with Empty From Headers

Incident Report for Inky

Resolved

Update has been made to correctly handle and deliver the emails to groups with an empty From header.
Posted Jul 23, 2025 - 16:51 UTC

Identified

We have identified an issue sending email to Microsoft Groups/Distribution Lists with Empty From Headers. Typically, this would only be older groups in a tenant with this configuration and a patch is being put together to handle these correctly.
Posted Jul 23, 2025 - 15:17 UTC
This incident affected: EMail Service (Office 365).