Office365 Exchange Issue - Some users may be unable to send, or see delays up to two hours when sending email messages
Incident Report for Inky
Resolved
Microsoft has closed the issue saying it has been resolved.

Mar 15, 2024, 12:01 PM CDT
Title: Some users may be unable to send, or see delays up to two hours when sending email messages through Exchange Online

User impact: Users may have been unable to send, or see delays up to two hours when sending, email messages through Exchange Online.

Final Status: We’ve received confirmation from impacted users that email messages are delivering as expected. The aforementioned persisting impact as reported by a small number of users isn’t related to this event.

Scope of impact: Some users who were serviced through the affected infrastructure and were sending email messages through any Exchange Online connection methods may have been impacted.

Start time: Sunday, March 10, 2024 at 2:00 PM CDT

End time: Thursday, March 14, 2024 at 1:41 PM CDT
.

Root cause: A recent change intended to resolve another ongoing issue was enabled and introduced unbalanced network traffic to the affected infrastructure, leading to impact.

Next steps:
- We're assessing how impact related to the change wasn't identified prior to deployment so that we can improve our change management processes.

This is the final update for the event.
Posted Mar 15, 2024 - 17:18 UTC
Update
EX736432 - O365 Admins should be able to see all updates and details in O365 Service Health Dashboard

Title: Some users may be unable to send, or see delays up to two hours when sending email messages through Exchange Online

User impact: Users may be unable to send, or see delays up to two hours when sending, email messages through Exchange Online.

More info: These failures and delays could occur when sending email through any Exchange Online connection method. Users may receive a Non-Delivery Report (NDR) when a message fails to send.

Current status: We're continuing to analyze some sample message IDs, as well as requesting extended message traces for those sample message IDs, to determine if additional mitigation actions are required to fully resolve the issue.

Scope of impact: Some users who are serviced through the affected infrastructure and are sending email messages through any Exchange Online connection methods may be impacted.

Start time: Sunday, March 10, 2024 at 2:00 PM CDT

Root cause: A recent change intended to resolve another ongoing issue was enabled and introduced unbalanced network traffic to the affected infrastructure, leading to impact.

Next update by: Friday, March 15, 2024 at 12:00 PM CDT
Posted Mar 15, 2024 - 12:09 UTC
Monitoring
Relaying information from Microsoft about an issue they are currently experiencing with Exchange Online

EX736432 - O365 Admins should be able to see all updates and details in O365 Service Health Dashboard

Title: Some users may be unable to send, or see delays up to two hours when sending email messages through Exchange Online

User impact: Users may be unable to send, or see delays up to two hours when sending, email messages through Exchange Online.

More info: These failures and delays could occur when sending email through any Exchange Online connection method. Users may receive a Non-Delivery Report (NDR) when a message fails to send.
Posted Mar 14, 2024 - 17:16 UTC
This incident affected: EMail Service (Office 365).