Reports of delays in sending email for teams using o365

Incident Report for Inky

Resolved

Inky Engineers monitored traffic from Microsoft overnight and no further disruptions or drops in traffic from Microsoft servers was detected.
Posted Jun 03, 2025 - 11:44 UTC

Monitoring

Inky engineers are monitoring to see if there is any further indication of deferrals being received from by customers from Microsoft.
Inky engineers did not identify any issues with connectivity between Inky and Microsoft but have noted that traffic from Microsoft dropped between 23:30 UT and 00:15 UT. Normal traffic resumed from Microsoft after that time.
Throughout that timeframe Inky was able to establish connections to and send traffic to Microsoft as normal.

Inky engineers are continuing to monitor.
Posted Jun 03, 2025 - 01:57 UTC

Investigating

We have received reports that some customers have seen a delay in mails getting from Microsoft to Inky. Some customers have received a deferral notification from Microsoft when attempting to hand mail to Inky for processing. At this time Inky systems are operating normally and we are investigating any possible connectivity issues between Inky and Microsoft.
Posted Jun 03, 2025 - 01:39 UTC
This incident affected: EMail Service (Office 365) and Email Processing (Inky Region 1 - Southeast US, Inky Region 2 - Eastern US, Inky Region 3 - Northwest US).