Outbound mail delays in EU region

Incident Report for Inky

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 13:07 UTC

Monitoring

Inky Engineers have restored normal mail processing times in the EU region and are monitoring to ensure stability.
Posted Mar 31, 2026 - 11:50 UTC

Identified

Inky Operations have identified what we believe is the issue and have taken corrective actions outbound mail delays should begin to return to normal levels.
Posted Mar 31, 2026 - 11:25 UTC

Investigating

We have detected a delay in outbound message processing in the Inky EU regions.
Posted Mar 31, 2026 - 11:17 UTC
This incident affected: Email Processing (Inky EU).