Slow down in Inky email processing in Inky legacy environment
Incident Report for Inky
Postmortem

Post incident report: Inky deferred incoming mail in Inky legacy.

Start: 29-July-2020 19:00 UTC

End: 29-July-2020 23:00 UTC

Duration: 4 hours

Summary:
At 19:00 UTC, A subset of Inky production services began deferring email being sent to Inky for analysis. AT 19:06 UTC, Inky engineers identified unusual latency in the analysis process specific to a subset of customers. At 20:59 UTC, additional processing capacity was added, which mitigated the impact of the latency. Engineers continued to mitigate and ensure normal mail flow was fully restored by 23:00 UTC. Email previously deferred by Inky systems was then processed as expected.

Root Cause:
Email message processing was slowed due to a processing delay in messages that triggered inappropriate response in the Inky processing system. This resulted in a drop-in capacity resulting in delays of inky mail processing.

Customer Impact:
Customer deferrals began at 19:00 UTC.

Mail was delayed as Inky processing systems deferred messages to customers until production capacity was increased at 20:59 UTC. Following the increase of capacity, deferred email was processed upon resubmission by customer email systems with full function returned by 23:00 UTC.

Mitigation Action:
Inky engineers increased capacity and neutralized the message type that had caused processing delays.

Follow-up Items and Preventative Measures:
• Inky has adjusted preprocessing configurations to identify messages that may cause processing issues and properly avoid impact.. -completed 29-July-2020
• Inky recommends migrating to Inky’s new production infrastructure.

Posted Jul 30, 2020 - 20:09 UTC

Resolved
This incident has been resolved and steps taken to prevent possible reoccurrence.
Posted Jul 30, 2020 - 20:07 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 30, 2020 - 12:51 UTC
Monitoring
We have mitigated the event and normal mail processing should resume.
Posted Jul 30, 2020 - 04:03 UTC
Update
Inky engineers have determined this event is affecting inky legacy processing environments.
Posted Jul 29, 2020 - 20:29 UTC
Investigating
Inky Engineers are investigating an incident resulting in a slow down in email processing times. This may result in mail being deferred by Inky. Engineers are investigating and to restore normal processing times.
Posted Jul 29, 2020 - 19:40 UTC
This incident affected: Email Processing (Inky Region 1 - Southeast US, Inky Region 2 - Eastern US, Inky Region 3 - Northwest US).